installing resynthesizer in 2.9.5?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

installing resynthesizer in 2.9.5?

Casey Connor-2
Hi -- what's the latest correct way to install resynthesizer in the
2.9.5 nightly, if that's in fact possible?

The version here <http://registry.gimp.org/node/27986> did not work for
me... ("/home/casey/.config/GIMP/2.9/plug-ins/resynthesizer: error while
loading shared libraries: libgimpui-2.0.so.0: wrong ELF class: ELFCLASS64")

I tried to git clone and build it but ./autogen.sh doesn't work; it
says: "configure: error: GIMP development libraries not found; please
install." -- not sure what to install to correct that.

Any thoughts? Seems like it's possible since it's in the pixls.us
AppImages? Thanks!

-c


_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: installing resynthesizer in 2.9.5?

Thorsten Stettin
Am 24.06.17 um 09:32 schrieb Casey Connor:

> Hi -- what's the latest correct way to install resynthesizer in the
> 2.9.5 nightly, if that's in fact possible?
>
> The version here <http://registry.gimp.org/node/27986> did not work
> for me... ("/home/casey/.config/GIMP/2.9/plug-ins/resynthesizer: error
> while loading shared libraries: libgimpui-2.0.so.0: wrong ELF class:
> ELFCLASS64")
>
> I tried to git clone and build it but ./autogen.sh doesn't work; it
> says: "configure: error: GIMP development libraries not found; please
> install." -- not sure what to install to correct that.
>
> Any thoughts? Seems like it's possible since it's in the pixls.us
> AppImages? Thanks!
>
> -c
>
>
What's your environment? Ubuntu, Debian, AUR, OpenSUSE...
> _______________________________________________
> gimp-user-list mailing list
> List address:    [hidden email]
> List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
> List archives:   https://mail.gnome.org/archives/gimp-user-list


--
Lao-Tse sagt: Nichtstun ist besser, als mit viel Mühe nichts zu schaffen.
Und er sagt auch: Ich habe drei Schätze, die ich hüte und hege.
Der eine ist die Liebe, der zweite ist die Genügsamkeit, der dritte ist die Demut.
Nur der Liebende ist mutig, nur der Genügsame ist großzügig, nur der Demütige ist fähig zu herrschen.



_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: installing resynthesizer in 2.9.5?

Thorsten Stettin
Am 24.06.17 um 09:56 schrieb [hidden email]:
> Yes indeed. :-)
Ok, you know I'm a little bit lazy, typical German. :-D
It means I build new Gimp 2.9.x packages on a weekly basis, I hope.

You can install the gimp-plugin-registry package. It contains
resynthesizer 2.0. AFAIK resynthesizer 2.0 from git is three years old.
The version resynthesizer 2.0 in the gimp-plugin-registry package should
be same as in git.
Ok, my source is
https://github.com/bzed/gimp-plugin-registry/tree/master/resynthesizer/resynthesizer-master

Check this out:

sudo apt install gimp-plugin-registry

Cheers

PS: I think I will build new Gimp 2.9.5 packages at night because:
When I wake up in the morning, love
And the sunlight hurts my eyes
And something without warning, love
Bears heavy on my mind


> I did:
>
> git clone https://github.com/bootchk/resynthesizer.git
> sudo apt-get install automake libglib2.0-dev libgimp2.0-dev intltool
> cd resynthesizer
> ./autogen.sh
>
> On 06/24/2017 12:47 AM, Thorsten Stettin wrote:
>> Am 24.06.17 um 09:44 schrieb [hidden email]:
>>> > What's your environment? Ubuntu, Debian, AUR, OpenSUSE...
>>>
>>> Sorry, I should have said: Kubuntu 16.10
>>>
>>> Thanks,
>>> -c
>>>
>> Are you using my "famous" gimp-edge ppa? :-D
>>
>
--
Lao-Tse sagt: Nichtstun ist besser, als mit viel Mühe nichts zu schaffen.
Und er sagt auch: Ich habe drei Schätze, die ich hüte und hege.
Der eine ist die Liebe, der zweite ist die Genügsamkeit, der dritte ist die Demut.
Nur der Liebende ist mutig, nur der Genügsame ist großzügig, nur der Demütige ist fähig zu herrschen.



_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: installing resynthesizer in 2.9.5?

Alexandre Prokoudine
24 июня 2017 г. 11:20 пользователь "Thorsten Stettin" <
[hidden email]> написал:


The version resynthesizer 2.0 in the gimp-plugin-registry package should be
same as in git.
Ok, my source is https://github.com/bzed/gimp-p
lugin-registry/tree/master/resynthesizer/resynthesizer-master


Why would you look at an outdated fork of the original git repository?

Alex
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: installing resynthesizer in 2.9.5?

Thorsten Stettin
Am 24.06.17 um 10:29 schrieb Alexandre Prokoudine:

> 24 июня 2017 г. 11:20 пользователь "Thorsten Stettin" <
> [hidden email]> написал:
>
>
> The version resynthesizer 2.0 in the gimp-plugin-registry package should be
> same as in git.
> Ok, my source is https://github.com/bzed/gimp-p
> lugin-registry/tree/master/resynthesizer/resynthesizer-master
>
>
> Why would you look at an outdated fork of the original git repository?
Oh, sorry for that. I use the sources which Bernd Zeimetz used.
https://github.com/bootchk/resynthesizer/tags
Oh, I see I have to build a new package.

Cheers
>
> Alex
> _______________________________________________
> gimp-user-list mailing list
> List address:    [hidden email]
> List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
> List archives:   https://mail.gnome.org/archives/gimp-user-list


--
Lao-Tse sagt: Nichtstun ist besser, als mit viel Mühe nichts zu schaffen.
Und er sagt auch: Ich habe drei Schätze, die ich hüte und hege.
Der eine ist die Liebe, der zweite ist die Genügsamkeit, der dritte ist die Demut.
Nur der Liebende ist mutig, nur der Genügsame ist großzügig, nur der Demütige ist fähig zu herrschen.



_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: installing resynthesizer in 2.9.5?

Casey Connor-2
In reply to this post by Thorsten Stettin
Just to close this thread -- when using the gimp-edge repo, installing
resynthesizer via gimp-plugin-registry worked for me.

Thank you to the maintainers.

-c

_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: installing resynthesizer in 2.9.5?

Casey Connor-2
See the signature at the end of all mailing list messages for the
unsubscribe link.

List managers: I'd like to re-suggest changing "List membership:" to
"Unsubscribe from list:" or similar and moving it to the head of the
list of links; especially for non-native english speakers maybe it would
help cut down on the frequent requests for unsubscription?

-c


On 06/25/2017 10:42 AM, Sherlock Ohms wrote:

> Please remove me from your mailing list. Thank you
> C:-)
>
>
> ------------------------------------------------------------------------
> *From:* Casey Connor <[hidden email]>
> *To:* "[hidden email]" <[hidden email]>
> *Sent:* Saturday, June 24, 2017 3:12 PM
> *Subject:* Re: [Gimp-user] installing resynthesizer in 2.9.5?
>
> Just to close this thread -- when using the gimp-edge repo, installing
> resynthesizer via gimp-plugin-registry worked for me.
>
> Thank you to the maintainers.
>
> -c
>
> _______________________________________________
> gimp-user-list mailing list
> List address: [hidden email] <mailto:[hidden email]>
> List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
> List archives: https://mail.gnome.org/archives/gimp-user-list
>
>

_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list