gimp-edit-copy

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

gimp-edit-copy

Peter Suetterlin

  Hi,

I recently switched to the 2.9 series of gimp(*).  Some of the script-fus I
regularly use do need babysitting, in particular the 'maximize local contrast'
script by Roy Johnson.  I fixed the deprecated function calls, but it always
failed in the final step where an edit buffer captured via gimp-edit-copy
should be pasted into a layer mask.

After some debugging on the script-fu console it turned out the reason for the
failure was that the edit buffer was empty.

I could fix the problem by selecting the full area before the call to
gimp-edit-copy.  But acording to the docs it should do this by itself if
nothing is selected.

Has this changed lately, or is it a bug to report?

I'm running openSUSE Tumbleweed, with a package from home:/Herbster0815.
It's called gimp-2.9.4-64.12, but reports itself as 2.9.5, so I don't know the
exact version but assume it's from git?

  Pit
 
(*) Really amazing!  You're doing a really great job on this.  I'll for sure
stick with 2.9

--
Dr. Peter "Pit" Suetterlin                 http://www.astro.su.se/~pit
Institute for Solar Physics
Tel.: +34 922 405 590  (Spain)             [hidden email]
      +46 8 5537 8559  (Sweden)            [hidden email]
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gimp-edit-copy

Michael Natterer
Hi Peter,

If any script works fine in 2.8, but not in git master,
please file a bug.

Regards,
Mitch

On Mon, 2017-04-17 at 11:05 +0100, Peter Suetterlin wrote:

>   Hi,
>
> I recently switched to the 2.9 series of gimp(*).  Some of the
> script-fus I
> regularly use do need babysitting, in particular the 'maximize local
> contrast'
> script by Roy Johnson.  I fixed the deprecated function calls, but it
> always
> failed in the final step where an edit buffer captured via gimp-edit-
> copy
> should be pasted into a layer mask.
>
> After some debugging on the script-fu console it turned out the
> reason for the
> failure was that the edit buffer was empty.
>
> I could fix the problem by selecting the full area before the call to
> gimp-edit-copy.  But acording to the docs it should do this by itself
> if
> nothing is selected.
>
> Has this changed lately, or is it a bug to report?
>
> I'm running openSUSE Tumbleweed, with a package from
> home:/Herbster0815.
> It's called gimp-2.9.4-64.12, but reports itself as 2.9.5, so I don't
> know the
> exact version but assume it's from git?
>
>   Pit
>   
> (*) Really amazing!  You're doing a really great job on this.  I'll
> for sure
> stick with 2.9
>
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gimp-edit-copy

Michael Natterer
In reply to this post by Peter Suetterlin
On Mon, 2017-04-17 at 11:05 +0100, Peter Suetterlin wrote:

>   Hi,
>
> I recently switched to the 2.9 series of gimp(*).  Some of the
> script-fus I
> regularly use do need babysitting, in particular the 'maximize local
> contrast'
> script by Roy Johnson.  I fixed the deprecated function calls, but it
> always
> failed in the final step where an edit buffer captured via gimp-edit-
> copy
> should be pasted into a layer mask.
>
> After some debugging on the script-fu console it turned out the
> reason for the
> failure was that the edit buffer was empty.
>
> I could fix the problem by selecting the full area before the call to
> gimp-edit-copy.  But acording to the docs it should do this by itself
> if
> nothing is selected.
>
> Has this changed lately, or is it a bug to report?
>
> I'm running openSUSE Tumbleweed, with a package from
> home:/Herbster0815.
> It's called gimp-2.9.4-64.12, but reports itself as 2.9.5, so I don't
> know the
> exact version but assume it's from git?
>
>   Pit
>   
> (*) Really amazing!  You're doing a really great job on this.  I'll
> for sure
> stick with 2.9

Oh, and thanks a lot! :)

_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gimp-edit-copy

Ofnuts-2
In reply to this post by Peter Suetterlin
On 17/04/17 12:05, Peter Suetterlin wrote:
> I could fix the problem by selecting the full area before the call to
> gimp-edit-copy.  But acording to the docs it should do this by itself if
> nothing is selected.
IMHO the real fix is to use other ways to move pixels. Applications
should not use the clipboard for their own purposes, this interferes
with the user's other apps.
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gimp-edit-copy

Peter Suetterlin
In reply to this post by Michael Natterer

  Hi Mitch,

Michael Natterer wrote:

> If any script works fine in 2.8, but not in git master,
> please file a bug.

OK, here:  https://bugzilla.gnome.org/show_bug.cgi?id=781408

Cheers,

   Pit
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gimp-edit-copy

Peter Suetterlin
In reply to this post by Ofnuts-2
Ofnuts wrote:
> On 17/04/17 12:05, Peter Suetterlin wrote:
> > I could fix the problem by selecting the full area before the call to
> > gimp-edit-copy.  But acording to the docs it should do this by itself if
> > nothing is selected.
> IMHO the real fix is to use other ways to move pixels. Applications should
> not use the clipboard for their own purposes, this interferes with the
> user's other apps.

Well, it isn't about getting the script to run on first place.  It's rather
that the docs say the function copies the whole drawable without a set
selection, but it seems it doesn't (it does in 2.8).

That is independent of what you intend to do with that buffer...

  Pit
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Loading...