compile help

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

compile help

John Griessen
what does it mean when you get this:

gimp: symbol lookup error: gimp: undefined symbol: gimp_convert_dither_type_compat_get_type

attempting to run the install,
and the GUI comes up when running in the build dir:

./app/gimp-2.10

To build, I ran this configure command:

./configure --prefix=/usr/local --datarootdir=/usr/local/share
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: compile help

Michael Schumacher
On April 18, 2018 11:31:53 AM GMT+02:00, John Griessen <[hidden email]> wrote:

>./configure --prefix=/usr/local

You should use a different prefix.


--
Regards,
Michael
GPG: 96A8 B38A 728A 577D 724D 60E5 F855 53EC B36D 4CDD
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: compile help

John Griessen
On 04/18/2018 05:28 AM, Michael Schumacher wrote:
>> ./configure --prefix=/usr/local
> You should use a different prefix.
such as --prefix=/usr/local/gimp-2.10
?

Thanks,

--
John Griessen
industromatic.com  Austin TX  building lab gear for biologists
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: compile help

John Griessen
In reply to this post by Michael Schumacher
On 04/18/2018 05:28 AM, Michael Schumacher wrote:
>> ./configure --prefix=/usr/local
> You should use a different prefix.

./configure --prefix=/usr/local/gimp
gets me a good GUI from any working dir.

How do I get rid of this message:

Missing fast-path babl conversion detected, Implementing missing babl fast paths
accelerates GEGL, GIMP and other software using babl, warnings are printed on
first occurance of formats used where a conversion has to be synthesized
programmatically by babl based on format description

Configure passed saying babl installed...

https://gist.github.com/jgriessen/5929128a744654944753d5f1e88d5abe

checking for recommended xgettext version (>= 0.19)... yes
checking for iso-codes... yes
checking for BABL... yes
checking for GEGL... yes
checking for ATK... yes
checking for pkg-config... (cached) /usr/bin/pkg-config
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list