Why 2.10.4 not 2.10.6 at my Debian

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Why 2.10.4 not 2.10.6 at my Debian

Users mailing list
Hello. I use Debian 9.5

https://www.gimp.org/news/2018/08/19/gimp-2-10-6-released/
says gimp 2.10.6
But

flatpak install https://flathub.org/repo/appstream/org.gimp.GIMP.flatpakref
says
error: App org.gimp.GIMP, branch stable is already installed

flatpak run org.gimp.GIMP -n &
runs GIMP but this gimp version is 2.10.4 not 2.10.6

apt-get install gimp
installs gimp 2.8 not 2.10

How can I run GIMP 2.10.6 ?

--
세벌식 http://sebul.sarang.net <http://sebul.sarang.net>
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: Why 2.10.4 not 2.10.6 at my Debian

Users mailing list
Hi!

On Fri, Sep 28, 2018 at 11:54 PM sebul via gimp-user-list <
[hidden email]> wrote:

> Hello. I use Debian 9.5
>
> https://www.gimp.org/news/2018/08/19/gimp-2-10-6-released/
> says gimp 2.10.6
> But
>
> flatpak install
> https://flathub.org/repo/appstream/org.gimp.GIMP.flatpakref
> says
> error: App org.gimp.GIMP, branch stable is already installed
>
> flatpak run org.gimp.GIMP -n &
> runs GIMP but this gimp version is 2.10.4 not 2.10.6
>
>
Flatpak has the last version, which is indeed 2.10.6. But maybe you
installed it when it was 2.10.4 and have not updated it yourself since.
Please run `flatpak update` to do so (if you have some desktop with deeper
flatpak support, like a recent GNOME, it could even propose you to update
by itself) and you should get GIMP 2.10.6.


> apt-get install gimp
> installs gimp 2.8 not 2.10
>

As many distributions, they are late in updating packages, and in
particular keep older versions for stability reasons (even though we think
GIMP 2.10 is stabler, sometimes "stable" means not breaking habits).
In any case, we don't maintain distribution packages. We don't know when
they will update.

>
> How can I run GIMP 2.10.6 ?
>

As explained above. :-)
Have fun!

Jehan


> --
> 세벌식 http://sebul.sarang.net <http://sebul.sarang.net>
> _______________________________________________
> gimp-user-list mailing list
> List address:    [hidden email]
> List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
> List archives:   https://mail.gnome.org/archives/gimp-user-list



--
ZeMarmot open animation film
http://film.zemarmot.net
Liberapay: https://liberapay.com/ZeMarmot/
Patreon: https://patreon.com/zemarmot
Tipeee: https://www.tipeee.com/zemarmot
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: Why 2.10.4 not 2.10.6 at my Debian

Users mailing list
Thank. But...

I run
flatpak update
and
flatpak run org.gimp.GIMP -n
and
I get
GIMP 2.10.2
Neither 2.10.6 nor 2.10.4

How can I get 2.10.6 ?

2018년 9월 30일 (일) 오전 12:21, Jehan Pagès <[hidden email]>님이 작성:

> Hi!
>
> On Fri, Sep 28, 2018 at 11:54 PM sebul via gimp-user-list <
> [hidden email]> wrote:
>
>> Hello. I use Debian 9.5
>>
>> https://www.gimp.org/news/2018/08/19/gimp-2-10-6-released/
>> says gimp 2.10.6
>> But
>>
>> flatpak install
>> https://flathub.org/repo/appstream/org.gimp.GIMP.flatpakref
>> says
>> error: App org.gimp.GIMP, branch stable is already installed
>>
>> flatpak run org.gimp.GIMP -n &
>> runs GIMP but this gimp version is 2.10.4 not 2.10.6
>>
>>
> Flatpak has the last version, which is indeed 2.10.6. But maybe you
> installed it when it was 2.10.4 and have not updated it yourself since.
> Please run `flatpak update` to do so (if you have some desktop with deeper
> flatpak support, like a recent GNOME, it could even propose you to update
> by itself) and you should get GIMP 2.10.6.
>
>
>> apt-get install gimp
>> installs gimp 2.8 not 2.10
>>
>
> As many distributions, they are late in updating packages, and in
> particular keep older versions for stability reasons (even though we think
> GIMP 2.10 is stabler, sometimes "stable" means not breaking habits).
> In any case, we don't maintain distribution packages. We don't know when
> they will update.
>
>>
>> How can I run GIMP 2.10.6 ?
>>
>
> As explained above. :-)
> Have fun!
>
> Jehan
>
>
>> --
>> 세벌식 http://sebul.sarang.net <http://sebul.sarang.net>
>> _______________________________________________
>> gimp-user-list mailing list
>> List address:    [hidden email]
>> List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
>> List archives:   https://mail.gnome.org/archives/gimp-user-list
>
>
>
> --
> ZeMarmot open animation film
> http://film.zemarmot.net
> Liberapay: https://liberapay.com/ZeMarmot/
> Patreon: https://patreon.com/zemarmot
> Tipeee: https://www.tipeee.com/zemarmot
>


--
세벌식 http://sebul.sarang.net <http://sebul.sarang.net>
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: Why 2.10.4 not 2.10.6 at my Debian

Users mailing list
On Tue, Oct 2, 2018 at 5:21 AM sebul <[hidden email]> wrote:

> Thank. But...
>
> I run
> flatpak update
> and
> flatpak run org.gimp.GIMP -n
> and
> I get
> GIMP 2.10.2
> Neither 2.10.6 nor 2.10.4
>
> How can I get 2.10.6 ?
>

Well that's the way.
Is something happening when running `flatpak update`? (like do you see
anything updating?)
Maybe you installed as user, in which case, you need to run: flatpak update
--user

Jehan


> 2018년 9월 30일 (일) 오전 12:21, Jehan Pagès <[hidden email]>님이 작성:
>
>> Hi!
>>
>> On Fri, Sep 28, 2018 at 11:54 PM sebul via gimp-user-list <
>> [hidden email]> wrote:
>>
>>> Hello. I use Debian 9.5
>>>
>>> https://www.gimp.org/news/2018/08/19/gimp-2-10-6-released/
>>> says gimp 2.10.6
>>> But
>>>
>>> flatpak install
>>> https://flathub.org/repo/appstream/org.gimp.GIMP.flatpakref
>>> says
>>> error: App org.gimp.GIMP, branch stable is already installed
>>>
>>> flatpak run org.gimp.GIMP -n &
>>> runs GIMP but this gimp version is 2.10.4 not 2.10.6
>>>
>>>
>> Flatpak has the last version, which is indeed 2.10.6. But maybe you
>> installed it when it was 2.10.4 and have not updated it yourself since.
>> Please run `flatpak update` to do so (if you have some desktop with
>> deeper flatpak support, like a recent GNOME, it could even propose you to
>> update by itself) and you should get GIMP 2.10.6.
>>
>>
>>> apt-get install gimp
>>> installs gimp 2.8 not 2.10
>>>
>>
>> As many distributions, they are late in updating packages, and in
>> particular keep older versions for stability reasons (even though we think
>> GIMP 2.10 is stabler, sometimes "stable" means not breaking habits).
>> In any case, we don't maintain distribution packages. We don't know when
>> they will update.
>>
>>>
>>> How can I run GIMP 2.10.6 ?
>>>
>>
>> As explained above. :-)
>> Have fun!
>>
>> Jehan
>>
>>
>>> --
>>> 세벌식 http://sebul.sarang.net <http://sebul.sarang.net>
>>> _______________________________________________
>>> gimp-user-list mailing list
>>> List address:    [hidden email]
>>> List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
>>> List archives:   https://mail.gnome.org/archives/gimp-user-list
>>
>>
>>
>> --
>> ZeMarmot open animation film
>> http://film.zemarmot.net
>> Liberapay: https://liberapay.com/ZeMarmot/
>> Patreon: https://patreon.com/zemarmot
>> Tipeee: https://www.tipeee.com/zemarmot
>>
>
>
> --
> 세벌식 http://sebul.sarang.net <http://sebul.sarang.net>
>


--
ZeMarmot open animation film
http://film.zemarmot.net
Liberapay: https://liberapay.com/ZeMarmot/
Patreon: https://patreon.com/zemarmot
Tipeee: https://www.tipeee.com/zemarmot
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: Why 2.10.4 not 2.10.6 at my Debian

Users mailing list
Thank you.
I run
$ flatpak update --user org.gimp.GIMP
and
I get 2.10.6 version.


2018년 10월 2일 (화) 오후 5:17, Jehan Pagès <[hidden email]>님이 작성:

>
>
> On Tue, Oct 2, 2018 at 5:21 AM sebul <[hidden email]> wrote:
>
>> Thank. But...
>>
>> I run
>> flatpak update
>> and
>> flatpak run org.gimp.GIMP -n
>> and
>> I get
>> GIMP 2.10.2
>> Neither 2.10.6 nor 2.10.4
>>
>> How can I get 2.10.6 ?
>>
>
> Well that's the way.
> Is something happening when running `flatpak update`? (like do you see
> anything updating?)
> Maybe you installed as user, in which case, you need to run: flatpak
> update --user
>
> Jehan
>
>
>> 2018년 9월 30일 (일) 오전 12:21, Jehan Pagès <[hidden email]>님이 작성:
>>
>>> Hi!
>>>
>>> On Fri, Sep 28, 2018 at 11:54 PM sebul via gimp-user-list <
>>> [hidden email]> wrote:
>>>
>>>> Hello. I use Debian 9.5
>>>>
>>>> https://www.gimp.org/news/2018/08/19/gimp-2-10-6-released/
>>>> says gimp 2.10.6
>>>> But
>>>>
>>>> flatpak install
>>>> https://flathub.org/repo/appstream/org.gimp.GIMP.flatpakref
>>>> says
>>>> error: App org.gimp.GIMP, branch stable is already installed
>>>>
>>>> flatpak run org.gimp.GIMP -n &
>>>> runs GIMP but this gimp version is 2.10.4 not 2.10.6
>>>>
>>>>
>>> Flatpak has the last version, which is indeed 2.10.6. But maybe you
>>> installed it when it was 2.10.4 and have not updated it yourself since.
>>> Please run `flatpak update` to do so (if you have some desktop with
>>> deeper flatpak support, like a recent GNOME, it could even propose you to
>>> update by itself) and you should get GIMP 2.10.6.
>>>
>>>
>>>> apt-get install gimp
>>>> installs gimp 2.8 not 2.10
>>>>
>>>
>>> As many distributions, they are late in updating packages, and in
>>> particular keep older versions for stability reasons (even though we think
>>> GIMP 2.10 is stabler, sometimes "stable" means not breaking habits).
>>> In any case, we don't maintain distribution packages. We don't know when
>>> they will update.
>>>
>>>>
>>>> How can I run GIMP 2.10.6 ?
>>>>
>>>
>>> As explained above. :-)
>>> Have fun!
>>>
>>> Jehan
>>>
>>>
>>>> --
>>>> 세벌식 http://sebul.sarang.net <http://sebul.sarang.net>
>>>> _______________________________________________
>>>> gimp-user-list mailing list
>>>> List address:    [hidden email]
>>>> List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
>>>> List archives:   https://mail.gnome.org/archives/gimp-user-list
>>>
>>>
>>>
>>> --
>>> ZeMarmot open animation film
>>> http://film.zemarmot.net
>>> Liberapay: https://liberapay.com/ZeMarmot/
>>> Patreon: https://patreon.com/zemarmot
>>> Tipeee: https://www.tipeee.com/zemarmot
>>>
>>
>>
>> --
>> 세벌식 http://sebul.sarang.net <http://sebul.sarang.net>
>>
>
>
> --
> ZeMarmot open animation film
> http://film.zemarmot.net
> Liberapay: https://liberapay.com/ZeMarmot/
> Patreon: https://patreon.com/zemarmot
> Tipeee: https://www.tipeee.com/zemarmot
>


--
세벌식 http://sebul.sarang.net <http://sebul.sarang.net>
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list