Text size editing issues with GIMP

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Text size editing issues with GIMP

Users mailing list
I've noticed this behavior recently with GIMP. It did not use to do this (at least not that I've noticed) in versions prior to 2.8.I use A LOT of text in several images I'm creating.
If I have a text object in an image and set the text size to say 38 points (specific size doesn't matter).I've noticed that on an increasing number of images that if I later try to go back and edit that text (after saving and later reopening the image)
the size of the text is suddenly changed to a huge value, eg 120 points.
It's strange, because all other aspects of the text remain intact (color, bold, underline, etc).In addition if a text object has multiple text sizes, the relationship between the sizes remains the same. eg 4 letters are 38 points, and 5 letters are 40 points, the new sizes will change to something like 120 and 122 respectively.Also the size doesn't always get bigger, sometimes it's changed to a tiny size like 1 point!
In the interim the text displayed, however, is the correct size, until you try to edit the text.And even then, the displayed text remains correct until you try to type in new text. At which point the text suddenly all jumps to this new wrong size.And this behavior is not affected by Undo. Meaning that after it does this, undo will NOT return the text to its original intended size.
This is happening on a whole bunch of my images, including ones I know I've edited before.This is also happening with new images that I later try to edit, along with my older images.There doesn't appear to be a consistent pattern with why it's happening, as other text retains it original size.It also doesn't appear related to a particular font.

Restarting the computer or GIMP changes nothing.I'm currently using GIMP 2.8.20 on Windows 7.I've attempted to update GIMP to resolve and the updates don't have any effect on this.

ThanksGeorge
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Text size editing issues with GIMP

Users mailing list

 

I've noticed this behavior recently with GIMP. It did not use to do this (at least not that I've noticed) in versions prior to 2.8.I use A LOT of text in several images I'm creating.
If I have a text object in an image and set the text size to say 38 points (specific size doesn't matter).I've noticed that on an increasing number of images that if I later try to go back and edit that text (after saving and later reopening the image)
the size of the text is suddenly changed to a huge value, eg 120 points.
It's strange, because all other aspects of the text remain intact (color, bold, underline, etc).In addition if a text object has multiple text sizes, the relationship between the sizes remains the same. eg 4 letters are 38 points, and 5 letters are 40 points, the new sizes will change to something like 120 and 122 respectively.Also the size doesn't always get bigger, sometimes it's changed to a tiny size like 1 point!
In the interim the text displayed, however, is the correct size, until you try to edit the text.And even then, the displayed text remains correct until you try to type in new text. At which point the text suddenly all jumps to this new wrong size.And this behavior is not affected by Undo. Meaning that after it does this, undo will NOT return the text to its original intended size.
This is happening on a whole bunch of my images, including ones I know I've edited before.This is also happening with new images that I later try to edit, along with my older images.There doesn't appear to be a consistent pattern with why it's happening, as other text retains it original size.It also doesn't appear related to a particular font.

Restarting the computer or GIMP changes nothing.I'm currently using GIMP 2.8.20 on Windows 7.I've attempted to update GIMP to resolve and the updates don't have any effect on this.
   
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list