Question about displayed values on Histogram window

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Question about displayed values on Histogram window

北嶋 凌
Hello.
I use GIMP ver.2.10.10.0 on Windows 7.

I have a question about Histogram window.
(Windows > Dockable Dialogs > Histogram)

There are "Mean","Std dev", "Median" values displayed,
but the values are between 0 and 1.
As far as I can remember, they used to be between 0 and 255.

e.g.
expect value: Red=0, Green=160,   Blue=233
displayed value: Red=0, Green=0.627, Blue=0.914

Is this because specification has changed,
or because I have changed some settings?

If this can be fixed by the settings, would you tell me how to set?

Best regards,

Ryo Kitashima
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: Question about displayed values on Histogram window

Users mailing list
Hello,

if you have an 8bit image it's from 0-255, if you have 16, or 32bit images
you get the values from 0-1.

Regards,
Tobias

Am Mo., 13. Mai 2019 um 11:45 Uhr schrieb 北嶋 凌 <[hidden email]>:

> Hello.
> I use GIMP ver.2.10.10.0 on Windows 7.
>
> I have a question about Histogram window.
> (Windows > Dockable Dialogs > Histogram)
>
> There are "Mean","Std dev", "Median" values displayed,
> but the values are between 0 and 1.
> As far as I can remember, they used to be between 0 and 255.
>
> e.g.
> expect value:    Red=0, Green=160,   Blue=233
> displayed value: Red=0, Green=0.627, Blue=0.914
>
> Is this because specification has changed,
> or because I have changed some settings?
>
> If this can be fixed by the settings, would you tell me how to set?
>
> Best regards,
>
> Ryo Kitashima
> _______________________________________________
> gimp-user-list mailing list
> List address:    [hidden email]
> List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
> List archives:   https://mail.gnome.org/archives/gimp-user-list
>
_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: Question about displayed values on Histogram window

北嶋 凌
Thank you for answering.
I had 24bit image, so converted into 8bit and read.
But values are still from 0-1.

Is that a correct way I did?

Best regards,

Ryo Kitashima

>Hello,
>
>if you have an 8bit image it's from 0-255, if you have 16, or 32bit images
>you get the values from 0-1.
>
>Regards,
>Tobias
>
>Am Mo., 13. Mai 2019 um 11:45 Uhr schrieb 北嶋 凌 <[hidden email]>:
>
>> Hello.
>> I use GIMP ver.2.10.10.0 on Windows 7.
>>
>> I have a question about Histogram window.
>> (Windows > Dockable Dialogs > Histogram)
>>
>> There are "Mean","Std dev", "Median" values displayed,
>> but the values are between 0 and 1.
>> As far as I can remember, they used to be between 0 and 255.
>>
>> e.g.
>> expect value:    Red=0, Green=160,   Blue=233
>> displayed value: Red=0, Green=0.627, Blue=0.914
>>
>> Is this because specification has changed,
>> or because I have changed some settings?
>>
>> If this can be fixed by the settings, would you tell me how to set?
>>
>> Best regards,
>>
>> Ryo Kitashima
>> _______________________________________________
>> gimp-user-list mailing list
>> List address:    [hidden email]
>> List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
>> List archives:   https://mail.gnome.org/archives/gimp-user-list
>>
>
>
>--------html-part included links-------
>mailto:[hidden email]
>mailto:[hidden email]

_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|

Re: Question about displayed values on Histogram window

北嶋 凌
In reply to this post by Users mailing list
Thank you for answering.

I had 24bit image, so converted into 8bit and read.
But values are still from 0-1.

Is that a correct way I did?

Best regards,

Ryo Kitashima

>Hello,
>
>if you have an 8bit image it's from 0-255, if you have 16, or 32bit images
>you get the values from 0-1.
>
>Regards,
>Tobias
>
>Am Mo., 13. Mai 2019 um 11:45 Uhr schrieb 北嶋 凌 <[hidden email]>:
>
>> Hello.
>> I use GIMP ver.2.10.10.0 on Windows 7.
>>
>> I have a question about Histogram window.
>> (Windows > Dockable Dialogs > Histogram)
>>
>> There are "Mean","Std dev", "Median" values displayed,
>> but the values are between 0 and 1.
>> As far as I can remember, they used to be between 0 and 255.
>>
>> e.g.
>> expect value:    Red=0, Green=160,   Blue=233
>> displayed value: Red=0, Green=0.627, Blue=0.914
>>
>> Is this because specification has changed,
>> or because I have changed some settings?
>>
>> If this can be fixed by the settings, would you tell me how to set?
>>
>> Best regards,
>>
>> Ryo Kitashima
>> _______________________________________________
>> gimp-user-list mailing list
>> List address:    [hidden email]
>> List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
>> List archives:   https://mail.gnome.org/archives/gimp-user-list
>>
>
>
>--------html-part included links-------
>mailto:[hidden email]
>mailto:[hidden email]

_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list