Quantcast

Odd tool behavior: pencil, eraser, and airbrush

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Odd tool behavior: pencil, eraser, and airbrush

Ross Martinek
OS 10.11.6, GIMP 2.8.18, Huion Tablet Driver 11.0.8.

Problem 1:
I have several custom pencils and erasers. The erasers are 1 pixel wide, 3 pixels wide, and 10 pixels wide. All the pencils are 1 pixel wide, but different colors, one of which is the default black.

When I switch from pencil to eraser, everything is fine. If I switch back without  changing the eraser, I get the same pencil with the same color. However, if I switch erasers before returning to the pencil, the pencil always switches to the default black color, rather than the color of the previously used pencil. This does not happen with any other tools.

Any ideas why this occurs and how to fix it?

Problem 2:
When switching tools the program sometimes doesn’t take the first click on a different tool. May take several. Occasionally it will seem to select the proper tool, but when I move onto the work area, the previous tool remains selected.

Is this possibly a tablet driver problem, or something else?


Problem 3:
When I first start using the tablet (not when first connected), GIMP switches to the airbrush tool, regardless of which tool was previously selected. It can take several tries to get the proper tool selected.

Is this possibly a tablet driver problem, or something else?

Ross


_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Odd tool behavior: pencil, eraser, and airbrush

Ofnuts-2
On 15/04/17 21:14, Ross Martinek wrote:

> OS 10.11.6, GIMP 2.8.18, Huion Tablet Driver 11.0.8.
>
> Problem 1:
> I have several custom pencils and erasers. The erasers are 1 pixel wide, 3 pixels wide, and 10 pixels wide. All the pencils are 1 pixel wide, but different colors, one of which is the default black.
>
> When I switch from pencil to eraser, everything is fine. If I switch back without  changing the eraser, I get the same pencil with the same color. However, if I switch erasers before returning to the pencil, the pencil always switches to the default black color, rather than the color of the previously used pencil. This does not happen with any other tools.
>
> Any ideas why this occurs and how to fix it?
>
> Problem 2:
> When switching tools the program sometimes doesn’t take the first click on a different tool. May take several. Occasionally it will seem to select the proper tool, but when I move onto the work area, the previous tool remains selected.
>
> Is this possibly a tablet driver problem, or something else?
>
>
> Problem 3:
> When I first start using the tablet (not when first connected), GIMP switches to the airbrush tool, regardless of which tool was previously selected. It can take several tries to get the proper tool selected.
>
> Is this possibly a tablet driver problem, or something else?
>
> Ross
>


What are the setting in Edit/Preferences:

* Tool options: "Save options on exit" or not? Any paint potions shared
between tools?
* Input devices: "Save input device settings on exit" or not?

If you have Windows>Dockable dialogs>Status, are the displayed tool
options (and active pointing device) coherent with what you experience?

_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Odd tool behavior: pencil, eraser, and airbrush

Ofnuts-2
Not an OSX user... I'm surprised you have three devices for you
tablet...  Also, according to the device status, one end of you stylus
as the eraser attached to it, while the other has the brush. And even
with this display you get the airbrush?

On 15/04/17 22:10, Ross Martinek wrote:

>
> Ross
>
>
>> On Apr 15, 2017, at 2:52 PM, Ofnuts <[hidden email]
>> <mailto:[hidden email]>> wrote:
>>
>> On 15/04/17 21:14, Ross Martinek wrote:
>>> OS 10.11.6, GIMP 2.8.18, Huion Tablet Driver 11.0.8.
>>>
>>> Problem 1:
>>> I have several custom pencils and erasers. The erasers are 1 pixel
>>> wide, 3 pixels wide, and 10 pixels wide. All the pencils are 1 pixel
>>> wide, but different colors, one of which is the default black.
>>>
>>> When I switch from pencil to eraser, everything is fine. If I switch
>>> back without  changing the eraser, I get the same pencil with the
>>> same color. However, if I switch erasers before returning to the
>>> pencil, the pencil always switches to the default black color,
>>> rather than the color of the previously used pencil. This does not
>>> happen with any other tools.
>>>
>>> Any ideas why this occurs and how to fix it?
>>>
>>> Problem 2:
>>> When switching tools the program sometimes doesn’t take the first
>>> click on a different tool. May take several. Occasionally it will
>>> seem to select the proper tool, but when I move onto the work area,
>>> the previous tool remains selected.
>>>
>>> Is this possibly a tablet driver problem, or something else?
>>>
>>>
>>> Problem 3:
>>> When I first start using the tablet (not when first connected), GIMP
>>> switches to the airbrush tool, regardless of which tool was
>>> previously selected. It can take several tries to get the proper
>>> tool selected.
>>>
>>> Is this possibly a tablet driver problem, or something else?
>>>
>>> Ross
>>>
>>
>>
>> What are the setting in Edit/Preferences:
>>
>> * Tool options: "Save options on exit" or not? Any paint potions
>> shared between tools?
>
> Save options on exit is checked.
> Shared between tools: Dynamics and Pattern.
>
>> * Input devices: "Save input device settings on exit" or not?
>
> Not checked.
>
>>
>> If you have Windows>Dockable dialogs>Status, are the displayed tool
>> options (and active pointing device) coherent with what you experience?
>
> Here is a picture of the Device status window. When I follow the steps
> I outlined, Core pointer changes from this brown to the default black
> when I switch erasers, then go back to the pen.
>
>>
>> _______________________________________________
>> gimp-user-list mailing list
>> List address: [hidden email] <mailto:[hidden email]>
>> List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
>> List archives: https://mail.gnome.org/archives/gimp-user-list
>

_______________________________________________
gimp-user-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list
Loading...