Missing dependencies when building Gimp with meson on Ubuntu 19.10

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing dependencies when building Gimp with meson on Ubuntu 19.10

Ofnuts-2
Trying my hand at: https://wiki.gimp.org/wiki/Hacking:Building

Installed all the prereqs listed in
https://wiki.gimp.org/wiki/Hacking:Building/Linux

Things went quite smoothly for all other packages: babl, gegl, mypaint.

Now trying the meson build for Gimp, it fails with two missing
dependencies (quotes added by me):

Library "socket" found: NO
Run-time dependency "xmu" found: NO (tried pkgconfig and cmake)

I do have these installed:

     >dpkg -l 'libsocket*'
     Desired=Unknown/Install/Remove/Purge/Hold
     |
Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
     |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
     ||/ Name               Version      Architecture Description
+++-==================-============-============-===============================================================
     ii  libsocket++1:amd64 1.12.13-10   amd64        lightweight
convenience library to handle low level BSD sockets

     >dpkg -l 'libxmu*'
     Desired=Unknown/Install/Remove/Purge/Hold
     |
Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
     |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
     ||/ Name           Version          Architecture Description
+++-==============-================-============-=======================================
     ii  libxmu6:amd64  2:1.1.3-0ubuntu1 amd64        X11 miscellaneous
utility library
     ii  libxmuu1:amd64 2:1.1.3-0ubuntu1 amd64        X11 miscellaneous
micro-utility library

Can't find any related ".pc" file. Are these the right packages?

OTOH the "classic" build worked well...





_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: Missing dependencies when building Gimp with meson on Ubuntu 19.10

Developers mailing list
Just a guess but you might want to install the dev packages, that is
libsocket++-dev and libxmu-dev

Le 06/03/2020 à 20:40, Ofnuts a écrit :

> Trying my hand at: https://wiki.gimp.org/wiki/Hacking:Building
>
> Installed all the prereqs listed in
> https://wiki.gimp.org/wiki/Hacking:Building/Linux
>
> Things went quite smoothly for all other packages: babl, gegl, mypaint.
>
> Now trying the meson build for Gimp, it fails with two missing
> dependencies (quotes added by me):
>
> Library "socket" found: NO
> Run-time dependency "xmu" found: NO (tried pkgconfig and cmake)
>
> I do have these installed:
>
>     >dpkg -l 'libsocket*'
>     Desired=Unknown/Install/Remove/Purge/Hold
>     |
> Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
>     |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
>     ||/ Name               Version      Architecture Description
> +++-==================-============-============-===============================================================
>
>     ii  libsocket++1:amd64 1.12.13-10   amd64        lightweight
> convenience library to handle low level BSD sockets
>
>     >dpkg -l 'libxmu*'
>     Desired=Unknown/Install/Remove/Purge/Hold
>     |
> Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
>     |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
>     ||/ Name           Version          Architecture Description
> +++-==============-================-============-=======================================
>
>     ii  libxmu6:amd64  2:1.1.3-0ubuntu1 amd64        X11 miscellaneous
> utility library
>     ii  libxmuu1:amd64 2:1.1.3-0ubuntu1 amd64        X11 miscellaneous
> micro-utility library
>
> Can't find any related ".pc" file. Are these the right packages?
>
> OTOH the "classic" build worked well...
>
>
>
>
>
> _______________________________________________
> gimp-developer-list mailing list
> List address:    [hidden email]
> List membership:
> https://mail.gnome.org/mailman/listinfo/gimp-developer-list
> List archives: https://mail.gnome.org/archives/gimp-developer-list
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: Missing dependencies when building Gimp with meson on Ubuntu 19.10

Ofnuts-2
That was it, thanks.

Still wondering why the "classic " build worked without these and why
"dpkg -l" doesn't list *all* uninstalled packages.


On 07/03/2020 08:40, Thomas Ferrand via gimp-developer-list wrote:

> Just a guess but you might want to install the dev packages, that is
> libsocket++-dev and libxmu-dev
>
> Le 06/03/2020 à 20:40, Ofnuts a écrit :
>> Trying my hand at: https://wiki.gimp.org/wiki/Hacking:Building
>>
>> Installed all the prereqs listed in
>> https://wiki.gimp.org/wiki/Hacking:Building/Linux
>>
>> Things went quite smoothly for all other packages: babl, gegl, mypaint.
>>
>> Now trying the meson build for Gimp, it fails with two missing
>> dependencies (quotes added by me):
>>
>> Library "socket" found: NO
>> Run-time dependency "xmu" found: NO (tried pkgconfig and cmake)
>>
>> I do have these installed:
>>
>>     >dpkg -l 'libsocket*'
>>     Desired=Unknown/Install/Remove/Purge/Hold
>>     |
>> Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
>>     |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
>>     ||/ Name               Version      Architecture Description
>> +++-==================-============-============-===============================================================
>>
>>     ii  libsocket++1:amd64 1.12.13-10   amd64        lightweight
>> convenience library to handle low level BSD sockets
>>
>>     >dpkg -l 'libxmu*'
>>     Desired=Unknown/Install/Remove/Purge/Hold
>>     |
>> Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
>>     |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
>>     ||/ Name           Version          Architecture Description
>> +++-==============-================-============-=======================================
>>
>>     ii  libxmu6:amd64  2:1.1.3-0ubuntu1 amd64        X11
>> miscellaneous utility library
>>     ii  libxmuu1:amd64 2:1.1.3-0ubuntu1 amd64        X11
>> miscellaneous micro-utility library
>>
>> Can't find any related ".pc" file. Are these the right packages?
>>
>> OTOH the "classic" build worked well...

_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list