Gimp-Perl plugin fails to compile.

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Gimp-Perl plugin fails to compile.

"Rikard Johnels"
Hell all!
I am desperatly trying to get the Perl module to compile/install but i have no
luck.

/build/Gimp-1.211 # perl Makefile.PL
loading cache ./config.cache
checking for gimp... (cached) /opt/gnome/bin/gimp
checking for gimptool... (cached) /opt/gnome/bin/gimptool
checking for GIMP - version >= 1.0.4... yes
checking for glib-config... (cached) /opt/gnome/bin/glib-config
checking for GLIB - version >= 1.2.0... yes
checking how to run the C preprocessor... (cached) cc -E
checking for libgimp/gimpmodule.h... (cached) yes
checking for libintl.h... (cached) yes
checking for unistd.h... (cached) yes
checking for vsnprintf... (cached) yes
checking for intelligent life... not found
checking for _exit... (cached) yes
creating ./config.status
creating config.pl
creating config.h
config.h is unchanged
now invoking perl to complete the configuration...
+ exec /usr/bin/perl Makefile.PL --writemakefile PREFIX=/usr

FATAL: unable to deduce plugindir from gimptool script


sparhawk:~ # rpm -q gimp
gimp-2.2.7-1.guru.suse92
sparhawk:~ # rpm -q gimp-devel
gimp-devel-2.2.7-1.guru.suse92


What am i missing here?

--

         /Rikard

" Sharing knowledge is the most fundamental act of friendship.
Because it is a way you can give something without loosing something."
                -R. Stallman

---------------------------------------------------------------
Rikard Johnels          email   : [hidden email]
                        Mob     : +46 763 19 76 25
                        PGP     : 0x461CEE56
---------------------------------------------------------------
_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user
Reply | Threaded
Open this post in threaded view
|

Re: Gimp-Perl plugin fails to compile.

Sven Neumann
Hi,

Rikard Johnels <[hidden email]> writes:

> I am desperatly trying to get the Perl module to compile/install
>  but i have no luck.
>
> /build/Gimp-1.211 # perl Makefile.PL
> loading cache ./config.cache
> checking for gimp... (cached) /opt/gnome/bin/gimp
> checking for gimptool... (cached) /opt/gnome/bin/gimptool
> checking for GIMP - version >= 1.0.4... yes
> checking for glib-config... (cached) /opt/gnome/bin/glib-config
> checking for GLIB - version >= 1.2.0... yes
> checking how to run the C preprocessor... (cached) cc -E
> checking for libgimp/gimpmodule.h... (cached) yes
> checking for libintl.h... (cached) yes
> checking for unistd.h... (cached) yes
> checking for vsnprintf... (cached) yes
> checking for intelligent life... not found
> checking for _exit... (cached) yes
> creating ./config.status
> creating config.pl
> creating config.h
> config.h is unchanged
> now invoking perl to complete the configuration...
> + exec /usr/bin/perl Makefile.PL --writemakefile PREFIX=/usr
>
> FATAL: unable to deduce plugindir from gimptool script
>
>
> sparhawk:~ # rpm -q gimp
> gimp-2.2.7-1.guru.suse92
> sparhawk:~ # rpm -q gimp-devel
> gimp-devel-2.2.7-1.guru.suse92

You are trying to compile/install a hopelessly outdated version of
Gimp-Perl.


Sven
_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user
Reply | Threaded
Open this post in threaded view
|

Re: Gimp-Perl plugin fails to compile.

"Rikard Johnels"
On Saturday 21 May 2005 00.30, you wrote:

> Hi,
>
> Rikard Johnels <[hidden email]> writes:
> > I am desperatly trying to get the Perl module to compile/install
> >  but i have no luck.
> >
> > /build/Gimp-1.211 # perl Makefile.PL
> > loading cache ./config.cache
> > checking for gimp... (cached) /opt/gnome/bin/gimp
> > checking for gimptool... (cached) /opt/gnome/bin/gimptool
> > checking for GIMP - version >= 1.0.4... yes
> > checking for glib-config... (cached) /opt/gnome/bin/glib-config
> > checking for GLIB - version >= 1.2.0... yes
> > checking how to run the C preprocessor... (cached) cc -E
> > checking for libgimp/gimpmodule.h... (cached) yes
> > checking for libintl.h... (cached) yes
> > checking for unistd.h... (cached) yes
> > checking for vsnprintf... (cached) yes
> > checking for intelligent life... not found
> > checking for _exit... (cached) yes
> > creating ./config.status
> > creating config.pl
> > creating config.h
> > config.h is unchanged
> > now invoking perl to complete the configuration...
> > + exec /usr/bin/perl Makefile.PL --writemakefile PREFIX=/usr
> >
> > FATAL: unable to deduce plugindir from gimptool script
> >
> >
> > sparhawk:~ # rpm -q gimp
> > gimp-2.2.7-1.guru.suse92
> > sparhawk:~ # rpm -q gimp-devel
> > gimp-devel-2.2.7-1.guru.suse92
>
> You are trying to compile/install a hopelessly outdated version of
> Gimp-Perl.
>
>
> Sven


So where can i find a newer version??
Its collected via perl CPAN a few days ago.
I thought this to be the latest...?


--

         /Rikard

" Sharing knowledge is the most fundamental act of friendship.
Because it is a way you can give something without loosing something."
                -R. Stallman

---------------------------------------------------------------
Rikard Johnels          email   : [hidden email]
                        Mob     : +46 763 19 76 25
                        PGP     : 0x461CEE56
---------------------------------------------------------------
_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user
Reply | Threaded
Open this post in threaded view
|

Re: Gimp-Perl plugin fails to compile.

Sven Neumann
Hi,

Rikard Johnels <[hidden email]> writes:

> So where can i find a newer version??
> Its collected via perl CPAN a few days ago.
> I thought this to be the latest...?

Use the Gimp-2.0 package from CPAN.


Sven
_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user
Reply | Threaded
Open this post in threaded view
|

Re: Gimp-Perl plugin fails to compile.

"Rikard Johnels"
On Sunday 22 May 2005 16.23, you wrote:

> Hi,
>
> Rikard Johnels <[hidden email]> writes:
> > So where can i find a newer version??
> > Its collected via perl CPAN a few days ago.
> > I thought this to be the latest...?
>
> Use the Gimp-2.0 package from CPAN.
>
>
> Sven

Please help a clueless individual...
How the (lots of bad words) do i get the beast installed??
I tried getting perl to build it by it self
#> perl -e shell -MCPAN
sparhawk:~ # perl -e shell -MCPAN

cpan shell -- CPAN exploration and modules installation (v1.7601)
ReadLine support enabled

cpan> install Gimp

And that pulled the module and failed to compile.
I then tried:
sparhawk:~ # cd .cpan/build/Gimp-1.211/
sparhawk:~/.cpan/build/Gimp-1.211 #
sparhawk:~/.cpan/build/Gimp-1.211 # perl Makefile.PL

And that too failed.

So how do i get it to find, download and finally successfully compile it???
 
--

         /Rikard

" Sharing knowledge is the most fundamental act of friendship.
Because it is a way you can give something without loosing something."
                -R. Stallman

---------------------------------------------------------------
Rikard Johnels          email   : [hidden email]
                        Mob     : +46 763 19 76 25
                        PGP     : 0x461CEE56
---------------------------------------------------------------
_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user
Reply | Threaded
Open this post in threaded view
|

Re: Gimp-Perl plugin fails to compile.

Sven Neumann
Hi,

Rikard Johnels <[hidden email]> writes:

> cpan> install Gimp

As I said already, you want to install "Gimp-2.0" instead of "Gimp".


Sven
_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user
Reply | Threaded
Open this post in threaded view
|

Re: Gimp-Perl plugin fails to compile.

"Rikard Johnels"
On Monday 23 May 2005 00.32, Sven Neumann wrote:
> Hi,
>
> Rikard Johnels <[hidden email]> writes:
> > cpan> install Gimp
>
> As I said already, you want to install "Gimp-2.0" instead of "Gimp".
>
>
> Sven
Ok.. Trying to get Gimp-2.0..

cpan> install Gimp-2.0
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
  Database was generated on Thu, 19 May 2005 01:55:39 GMT
CPAN: LWP::UserAgent loaded ok
Fetching with LWP:
  ftp://ftp.du.se/pub/CPAN/authors/01mailrc.txt.gz
Going to read /root/.cpan/sources/authors/01mailrc.txt.gz
CPAN: Compress::Zlib loaded ok
Fetching with LWP:
  ftp://ftp.du.se/pub/CPAN/modules/02packages.details.txt.gz
Going to read /root/.cpan/sources/modules/02packages.details.txt.gz
  Database was generated on Mon, 23 May 2005 09:57:03 GMT
Fetching with LWP:
  ftp://ftp.du.se/pub/CPAN/modules/03modlist.data.gz
Going to read /root/.cpan/sources/modules/03modlist.data.gz
Going to write /root/.cpan/Metadata
Warning: Cannot install Gimp-2.0, don't know what it is.
Try the command

    i /Gimp-2.0/

to find objects with matching identifiers.

cpan> i /Gimp-2.0/
No objects found of any type for argument /Gimp-2.0/

cpan> i /Gimp2/
No objects found of any type for argument /Gimp2/

cpan>i /Gimp/
Author          GIMPIT ("Jay Scherrer" <[hidden email]>)
Distribution    M/ML/MLEHMANN/Gimp-1.211.tar.gz
Module          Data::Stag::StagImpl (C/CM/CMUNGALL/Data-Stag-0.09.tar.gz)
Module          Gimp            (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::Compat    (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::Data      (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::Feature   (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::Fu        (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::Lib       (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::Module    (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::Net       (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::PDL       (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::Pod       (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::UI        (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::Util      (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
Module          Gimp::basewidget (M/ML/MLEHMANN/Gimp-1.211.tar.gz)
16 items found




So i have still no clues on how to get Gimp-2.0.

--

         /Rikard

" Sharing knowledge is the most fundamental act of friendship.
Because it is a way you can give something without loosing something."
                -R. Stallman

---------------------------------------------------------------
Rikard Johnels          email   : [hidden email]
                        Mob     : +46 763 19 76 25
                        PGP     : 0x461CEE56
---------------------------------------------------------------
_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user
Reply | Threaded
Open this post in threaded view
|

Re: Gimp-Perl plugin fails to compile.

Carol Spears
On Mon, May 23, 2005 at 04:49:51PM +0200, Rikard Johnels wrote:

> On Monday 23 May 2005 00.32, Sven Neumann wrote:
> > Hi,
> >
> > Rikard Johnels <[hidden email]> writes:
> > > cpan> install Gimp
> >
> > As I said already, you want to install "Gimp-2.0" instead of "Gimp".
> >
> >
> > Sven
> Ok.. Trying to get Gimp-2.0..
>
You can get it two ways that i know of:

the tarball is available at
ftp://ftp.gimp.org/pub/gimp/plug-ins/v2.0/perl/

or you can get it from gnomecvs:
 export CVSROOT=':pserver:[hidden email]:/cvs/gnome' then
 cvs checkout gimp-perl

I dont know what is wrong with CPAN.

thanks,
carol

_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user
Reply | Threaded
Open this post in threaded view
|

Re: Gimp-Perl plugin fails to compile.

"Rikard Johnels"
On Tuesday 24 May 2005 16.48, Carol Spears wrote:

> On Mon, May 23, 2005 at 04:49:51PM +0200, Rikard Johnels wrote:
> > On Monday 23 May 2005 00.32, Sven Neumann wrote:
> > > Hi,
> > >
> > > Rikard Johnels <[hidden email]> writes:
> > > > cpan> install Gimp
> > >
> > > As I said already, you want to install "Gimp-2.0" instead of "Gimp".
> > >
> > >
> > > Sven
> >
> > Ok.. Trying to get Gimp-2.0..
>
> You can get it two ways that i know of:
>
> the tarball is available at
> ftp://ftp.gimp.org/pub/gimp/plug-ins/v2.0/perl/
>
> or you can get it from gnomecvs:
>  export CVSROOT=':pserver:[hidden email]:/cvs/gnome' then
>  cvs checkout gimp-perl
>
> I dont know what is wrong with CPAN.
>
> thanks,
> carol

Ok. Got it from the ftp.
It still barfs the shit out of itself:

rikjoh@sparhawk:~/build/Gimp-2.0> perl Makefile.PL
checking for gimp-2.0... no
checking for gcc... cc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ANSI C... none needed
checking for gimptool-2.0... /opt/gnome/bin/gimptool-2.0
checking for GIMP - version >= 2.0.0... yes
checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0... yes (version 2.4.6)
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... yes (version 2.4.9)
checking how to run the C preprocessor... cc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking libgimp/gimpmodule.h usability... no
checking libgimp/gimpmodule.h presence... yes
configure: WARNING: libgimp/gimpmodule.h: present but cannot be compiled
configure: WARNING: libgimp/gimpmodule.h: check for missing prerequisite
headers?
configure: WARNING: libgimp/gimpmodule.h: proceeding with the preprocessor's
result
configure: WARNING:     ## ------------------------------------ ##
configure: WARNING:     ## Report this to [hidden email]. ##
configure: WARNING:     ## ------------------------------------ ##
checking for libgimp/gimpmodule.h... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for unistd.h... (cached) yes
checking for vsnprintf... yes
checking for intelligent life... found a cat in your bin
checking for _exit... yes
configure: creating ./config.status
config.status: creating config.pl
config.status: creating config.h
now invoking perl to complete the configuration...

WARNING: unable to use PDL (the perl data language). This means that
         normal pixel access is non-functional. Unless you plan to use
         Tile/PixelRgn functions together with PDL, this is harmless. The
         plug-ins using PDL, however, will NOT WORK and you can NO LONGER
         install PDL later. You can get PDL from any CPAN mirror.

checking for PDL support... no

NOTICE:  unable to use the Perl-Gtk2 interface. Many features (like
         Gimp::Fu) rely on this extension. You can build without it (and
         many scripts will be disabled or run with reduced functionality
         only), but it's better to install it.  If you do install it,
         version 1.0 or higher is required; you can get it from
         http://gtk2-perl.sourceforge.net/ or any CPAN mirror.

writing Gimp/Config.pm... ok
Checking if your kit is complete...
Looks good
Warning: prerequisite Gtk2 1 not found.
Warning: prerequisite PDL 1.99 not found.
use'ing Gimp::PDL is no longer necessary, please remove it!
Writing Makefile for Gimp::Lib
Writing Makefile for Gimp::Net
ERROR from evaluation of /home/rikjoh/build/Gimp-2.0/UI/Makefile.PL: Can't
locate ExtUtils/Depends.pm in @INC (@INC
contains: /usr/lib/perl5/5.8.5/i586-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl .)
at ./Makefile.PL line 2.
BEGIN failed--compilation aborted at ./Makefile.PL line 2.


What puzzles me is:
"WARNING: unable to use PDL (the perl data language) ... You can get PDL from
any CPAN mirror."
and
"use'ing Gimp::PDL is no longer necessary, please remove it!"

That is a very odd conflict of directives!

I am getting a wee bit fed up with trying to compile all this.
The prospect of getting into PS just to get the things i want to use seems
closer and closer.

Gimp seems to be a VERY difficult piece of software to get going from scratch
if you are a dabbling neewbie in compiling/programming
Far to many depends that arent clearly stated.
I need gazillion libs installed and zonks of perl utils to even THINK of
starting a compilation.
And frankly.. It suck!

--

         /Rikard

" Sharing knowledge is the most fundamental act of friendship.
Because it is a way you can give something without loosing something."
                -R. Stallman

---------------------------------------------------------------
Rikard Johnels          email   : [hidden email]
                        Mob     : +46 763 19 76 25
                        PGP     : 0x461CEE56
---------------------------------------------------------------
_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user
Reply | Threaded
Open this post in threaded view
|

Re: Gimp-Perl plugin fails to compile.

Owen-24
On Tue, 24 May 2005 22:08:16 +0200
Rikard Johnels <[hidden email]> wrote:

> ERROR from evaluation of /home/rikjoh/build/Gimp-2.0/UI/Makefile.PL: Can't
> locate ExtUtils/Depends.pm in @INC (@INC


Looks like you dont have ExtUtils::Depends

Try installing that via cpan




Owen
_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user
Reply | Threaded
Open this post in threaded view
|

Re: Gimp-Perl plugin fails to compile.

"Rikard Johnels"
In reply to this post by "Rikard Johnels"
On Wednesday 25 May 2005 01.19, Carol Spears wrote:
> On Tue, May 24, 2005 at 11:59:46PM +0200, Rikard Johnels wrote:
> > So does the few script-fu i have installed. (ufraw, and a few panorama
> > tools)
>
> how about my apology for the state of the freesoftware and the free even
> though you bought it software?
>
> carol

No need to apologize!
Usercommunity software like Gimp IS (inherently) not complete.
But then again not all commercial ones are either :)

Gimp as it is is very nice. And maturing all the time.
What bugs me is the "lack of ease" in compiling it.
There aren't any clear lists of dependencies and prerequisites listed
anywhere.
All you get is an error at either config or compile time.
And not all of them are easy to resolve.

It would be so much easier if there was a small file or something, listing
what libs and utils need to be installed to compile the software.
I think that would cut a lot of the usual questions on the lists.
The same "i cant compile" type questions keep creeping up.
And most of them seem to be old or missing libs.
A list of used ones would ease things up for us "dont have a clue" kind of
ppl :)

Just my 2 cents...

--

         /Rikard

" Sharing knowledge is the most fundamental act of friendship.
Because it is a way you can give something without loosing something."
                -R. Stallman

---------------------------------------------------------------
Rikard Johnels          email   : [hidden email]
                        Mob     : +46 763 19 76 25
                        PGP     : 0x461CEE56
---------------------------------------------------------------
_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user
Reply | Threaded
Open this post in threaded view
|

Re: Gimp-Perl plugin fails to compile.

Michael Schumacher
In reply to this post by "Rikard Johnels"
Von: Rikard Johnels <[hidden email]>

> Gimp seems to be a VERY difficult piece of software to get going from
> scratch if you are a dabbling neewbie in compiling/programming

Yes. If you want something easy, compile a hello.c...

> Far to many depends that arent clearly stated.

Form Gimp-Perl's README:

"PREREQUISITES
[...]
Gtk, the perl extension for gtk+2
http://gtk2-perl.sourceforge.net
[...]
PDL, the Perl Data Language
http://www.cpan.org/
[...]
"

> I need gazillion libs installed and zonks of perl utils to even THINK of
> starting a compilation.

Yes. Your package manager will help you to get all of them easily, though
(if you don't have a package manager of it fails to do this easily, your're
using the wrong platform)

> And frankly.. It suck!

I'll refuse to comment on this, because all the replies I can think of are
insulting :)


HTH,
Michael

--
5 GB Mailbox, 50 FreeSMS http://www.gmx.net/de/go/promail
+++ GMX - die erste Adresse f?r Mail, Message, More +++
_______________________________________________
Gimp-user mailing list
[hidden email]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user