GIT version doesn't compile with libmypaint (GIT version)

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

GIT version doesn't compile with libmypaint (GIT version)

Helmut Jarausch
Hi,
4 days ago, mypaint_brush_stroke_to has been changed to take two  
additional parameters
float viewzoom, float viewrotation

This makes compilation of gimpmybrushcore.c fail.

What are the correct additional arguments to mypaint_brush_stroke_to  (  
0.0, 0.0) ?

Many thanks for a hint,
Helmut
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GIT version doesn't compile with libmypaint (GIT version)

Alexandre Prokoudine
The new arguments are viewzoom and viewrotation. Please either revert to
libmypaint 1.3.0 or provide a patch for GIMP (it pobably won't be an easy
one, for prerequisites it's likely to involve).

Alex

21 июня 2017 г. 16:38 пользователь "Helmut Jarausch" <[hidden email]>
написал:

> Hi,
> 4 days ago, mypaint_brush_stroke_to has been changed to take two
> additional parameters
> float viewzoom, float viewrotation
>
> This makes compilation of gimpmybrushcore.c fail.
>
> What are the correct additional arguments to mypaint_brush_stroke_to  (
> 0.0, 0.0) ?
>
> Many thanks for a hint,
> Helmut
> _______________________________________________
> gimp-developer-list mailing list
> List address:    [hidden email]
> List membership: https://mail.gnome.org/mailman
> /listinfo/gimp-developer-list
> List archives:   https://mail.gnome.org/archives/gimp-developer-list
>
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GIT version doesn't compile with libmypaint (GIT version)

Developers mailing list
In reply to this post by Helmut Jarausch
Hello i wanted to ask you if it was possible to unsubscribe from your community and services all link to GIMP developer, thanks.

[hidden email]



--------------------------------------------
En date de : Mer 21.6.17, Alexandre Prokoudine <[hidden email]> a écrit :

 Objet: Re: [Gimp-developer] GIT version doesn't compile with libmypaint (GIT version)
 À:
 Cc: "gimp-developer" <[hidden email]>
 Date: Mercredi 21 juin 2017, 16h33
 
 The new arguments are viewzoom
 and viewrotation. Please either revert to
 libmypaint 1.3.0 or provide a patch for GIMP
 (it pobably won't be an easy
 one, for
 prerequisites it's likely to involve).
 
 Alex
 
 21 июня 2017 г. 16:38
 пользователь "Helmut Jarausch" <[hidden email]>
 написал:
 
 > Hi,
 > 4 days ago,
 mypaint_brush_stroke_to has been changed to take two
 > additional parameters
 >
 float viewzoom, float viewrotation
 >
 > This makes compilation of
 gimpmybrushcore.c fail.
 >
 > What are the correct additional arguments
 to mypaint_brush_stroke_to  (
 > 0.0,
 0.0) ?
 >
 > Many thanks
 for a hint,
 > Helmut
 >
 _______________________________________________
 > gimp-developer-list mailing list
 > List address:    [hidden email]
 > List membership: https://mail.gnome.org/mailman
 > /listinfo/gimp-developer-list
 > List archives:   https://mail.gnome.org/archives/gimp-developer-list
 >
 _______________________________________________
 gimp-developer-list mailing list
 List address:    [hidden email]
 List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
 List archives:   https://mail.gnome.org/archives/gimp-developer-list
 
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GIT version doesn't compile with libmypaint (GIT version)

Øyvind Kolås-2
On Wed, Jun 21, 2017 at 5:04 PM, Norbert Beloud via
gimp-developer-list <[hidden email]> wrote:
> Hello i wanted to ask you if it was possible to unsubscribe from your community and services all link to GIMP developer, thanks.
>
> [hidden email]

It is, at the bottom of every mail you get delivered from this
mailinglist the following footer should be affixed:

----
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
----

Unsubscribing is self-managed just like subscribing, investigate the
'Link membership' link for further information.

/pippin
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GIT version doesn't compile with libmypaint (GIT version)

b91502038
In reply to this post by Helmut Jarausch
In my study
viewzoom : Effects speed-related parameters like Fine speed, Gross speed,
Offset by speed.
viewrotation : Add this value to angles of elliptic dab and direction
parameter, measured in radius. Seems to effect tilt too but I don't have a
tilt-supporting tablet to test it.

From their names they seem to be used with canvas zooming and rotation.
Since GIMP already calculates canvas zooming and rotation by itself, just
set them as default values, which are viewzoom=1, viewrotation=0.

If you need a patch, here:
https://drive.google.com/open?id=0ByvJcJmOQlkRNVVhREtneEZHYmc

_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GIT version doesn't compile with libmypaint (GIT version)

Michael Schumacher
Am 21.06.2017 um 22:44 schrieb shark0r:

> In my study
> viewzoom : Effects speed-related parameters like Fine speed, Gross
> speed, Offset by speed.
> viewrotation : Add this value to angles of elliptic dab and direction
> parameter, measured in radius. Seems to effect tilt too but I don't have
> a tilt-supporting tablet to test it.
>
> From their names they seem to be used with canvas zooming and rotation.
> Since GIMP already calculates canvas zooming and rotation by itself,
> just set them as default values, which are viewzoom=1, viewrotation=0.
>
> If you need a patch, here:
> https://drive.google.com/open?id=0ByvJcJmOQlkRNVVhREtneEZHYmc

The libmypaint master branch is supposed to be unstable right now, see

https://github.com/mypaint/libmypaint/issues/92


The best approach would likely be to let the libmypaint developers
finish these changes and then check what needs to be changed for GIMP.

--
Regards,
Michael
GPG: 96A8 B38A 728A 577D 724D 60E5 F855 53EC B36D 4CDD
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Loading...