GEGL build failure

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

GEGL build failure

Developers mailing list
partha@Parthas-MacBook-Pro gegl % ninja install
[1/722] Linking static target subprojects/poly2tri-c/libpoly2tri-c.a
FAILED: subprojects/poly2tri-c/libpoly2tri-c.a
rm -f subprojects/poly2tri-c/libpoly2tri-c.a && ar csr
subprojects/poly2tri-c/libpoly2tri-c.a ar: no archive members specified
usage:  ar -d [-TLsv] archive file ...
ar -m [-TLsv] archive file ...
ar -m [-abiTLsv] position archive file ...
ar -p [-TLsv] archive [file ...]
ar -q [-cTLsv] archive file ...
ar -r [-cuTLsv] archive file ...
ar -r [-abciuTLsv] position archive file ...
ar -t [-TLsv] archive [file ...]
ar -x [-ouTLsv] archive [file ...]
[10/722] Compiling C object 'libs/rgbe/2e83b36@@rgbe@sta/rgbe.c.o'
ninja: build stopped: subcommand failed.


This will work on Linux and Windows but not on Mac. I work around it but
probably better to fix it at the source.

Thanks,
Partha
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL build failure

Developers mailing list
Hi Partha

Have a look at this issue, seems to be related
https://gitlab.gnome.org/GNOME/gegl/-/issues/214



On Sun, 27 Sep 2020 at 05:08, Partha Bagchi via gimp-developer-list <
[hidden email]> wrote:

> partha@Parthas-MacBook-Pro gegl % ninja install
> [1/722] Linking static target subprojects/poly2tri-c/libpoly2tri-c.a
> FAILED: subprojects/poly2tri-c/libpoly2tri-c.a
> rm -f subprojects/poly2tri-c/libpoly2tri-c.a && ar csr
> subprojects/poly2tri-c/libpoly2tri-c.a ar: no archive members specified
> usage:  ar -d [-TLsv] archive file ...
> ar -m [-TLsv] archive file ...
> ar -m [-abiTLsv] position archive file ...
> ar -p [-TLsv] archive [file ...]
> ar -q [-cTLsv] archive file ...
> ar -r [-cuTLsv] archive file ...
> ar -r [-abciuTLsv] position archive file ...
> ar -t [-TLsv] archive [file ...]
> ar -x [-ouTLsv] archive [file ...]
> [10/722] Compiling C object 'libs/rgbe/2e83b36@@rgbe@sta/rgbe.c.o'
> ninja: build stopped: subcommand failed.
>
>
> This will work on Linux and Windows but not on Mac. I work around it but
> probably better to fix it at the source.
>
> Thanks,
> Partha
> _______________________________________________
> gimp-developer-list mailing list
> List address:    [hidden email]
> List membership:
> https://mail.gnome.org/mailman/listinfo/gimp-developer-list
> List archives:   https://mail.gnome.org/archives/gimp-developer-list
>


--
<https://about.me/gregory.reshetniak?promo=email_sig&utm_source=product&utm_medium=email_sig&utm_campaign=edit_panel&utm_content=thumb>
Gregory Reshetniak
about.me/gregory.reshetniak
<https://about.me/gregory.reshetniak?promo=email_sig&utm_source=product&utm_medium=email_sig&utm_campaign=edit_panel&utm_content=thumb>
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL build failure

Developers mailing list
Thanks for pointing that out.

Yes, empty archives cannot be compiled on Mac. So, you can use an empty
dummy file or combine the 2 lines in ninja. It's not a meson bug.

On Sun, Sep 27, 2020 at 6:04 AM Gregory Reshetniak <[hidden email]> wrote:

> Hi Partha
>
> Have a look at this issue, seems to be related
> https://gitlab.gnome.org/GNOME/gegl/-/issues/214
>
>
>
> On Sun, 27 Sep 2020 at 05:08, Partha Bagchi via gimp-developer-list <
> [hidden email]> wrote:
>
>> partha@Parthas-MacBook-Pro gegl % ninja install
>> [1/722] Linking static target subprojects/poly2tri-c/libpoly2tri-c.a
>> FAILED: subprojects/poly2tri-c/libpoly2tri-c.a
>> rm -f subprojects/poly2tri-c/libpoly2tri-c.a && ar csr
>> subprojects/poly2tri-c/libpoly2tri-c.a ar: no archive members specified
>> usage:  ar -d [-TLsv] archive file ...
>> ar -m [-TLsv] archive file ...
>> ar -m [-abiTLsv] position archive file ...
>> ar -p [-TLsv] archive [file ...]
>> ar -q [-cTLsv] archive file ...
>> ar -r [-cuTLsv] archive file ...
>> ar -r [-abciuTLsv] position archive file ...
>> ar -t [-TLsv] archive [file ...]
>> ar -x [-ouTLsv] archive [file ...]
>> [10/722] Compiling C object 'libs/rgbe/2e83b36@@rgbe@sta/rgbe.c.o'
>> ninja: build stopped: subcommand failed.
>>
>>
>> This will work on Linux and Windows but not on Mac. I work around it but
>> probably better to fix it at the source.
>>
>> Thanks,
>> Partha
>> _______________________________________________
>> gimp-developer-list mailing list
>> List address:    [hidden email]
>> List membership:
>> https://mail.gnome.org/mailman/listinfo/gimp-developer-list
>> List archives:   https://mail.gnome.org/archives/gimp-developer-list
>>
>
>
> --
>
> <https://about.me/gregory.reshetniak?promo=email_sig&utm_source=product&utm_medium=email_sig&utm_campaign=edit_panel&utm_content=thumb>
> Gregory Reshetniak
> about.me/gregory.reshetniak
> <https://about.me/gregory.reshetniak?promo=email_sig&utm_source=product&utm_medium=email_sig&utm_campaign=edit_panel&utm_content=thumb>
>
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list