GEGL Drop Shadow filter not working

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

GEGL Drop Shadow filter not working

julien-5
Hi devs,

With Gimp-2.10.8 and Gimp-2.99, under different systems and computers,
the Drop Shadow filter doesn't work: nothing happens when I use it.
(Drop Shadow (legacy) works perfectly)

Is this due to work in progress or to something I don't understand in
using it?

Julien

_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

Developers mailing list
The layer has to be the size of the canvas or at least somewhat larger than
its contents

Alex

ср, 2 янв. 2019 г., 20:39 Julien Hardelin [hidden email]:

> Hi devs,
>
> With Gimp-2.10.8 and Gimp-2.99, under different systems and computers,
> the Drop Shadow filter doesn't work: nothing happens when I use it.
> (Drop Shadow (legacy) works perfectly)
>
> Is this due to work in progress or to something I don't understand in
> using it?
>
> Julien
>
> _______________________________________________
> gimp-developer-list mailing list
> List address:    [hidden email]
> List membership:
> https://mail.gnome.org/mailman/listinfo/gimp-developer-list
> List archives:   https://mail.gnome.org/archives/gimp-developer-list
>
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

Developers mailing list
On Thu, Jan 03, 2019 at 12:38:41AM +0300, Alexandre Prokoudine via gimp-developer-list wrote:
> The layer has to be the size of the canvas or at least somewhat larger than
> its contents

What do you mean with this? I create a new image, create a selection in
it, fill it with black and start the filter. Nothing happens. What should
I do to make it work?

--


Marco Ciampa

I know a joke about UDP, but you might not get it.

------------------------

 GNU/Linux User #78271
 FSFE fellow #364

------------------------

_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

julien-5
In reply to this post by Developers mailing list
I tried this before posting, using Layer Boundary Size to make the layer
size bigger : it doesn't work.

Le 02/01/2019 à 22:38, Alexandre Prokoudine a écrit :

> The layer has to be the size of the canvas or at least somewhat larger
> than its contents
>
> Alex
>
> ср, 2 янв. 2019 г., 20:39 Julien Hardelin [hidden email]
> <mailto:[hidden email]>:
>
>     Hi devs,
>
>     With Gimp-2.10.8 and Gimp-2.99, under different systems and
>     computers,
>     the Drop Shadow filter doesn't work: nothing happens when I use it.
>     (Drop Shadow (legacy) works perfectly)
>
>     Is this due to work in progress or to something I don't understand in
>     using it?
>
>     Julien
>
>     _______________________________________________
>     gimp-developer-list mailing list
>     List address: [hidden email]
>     <mailto:[hidden email]>
>     List membership:
>     https://mail.gnome.org/mailman/listinfo/gimp-developer-list
>     List archives: https://mail.gnome.org/archives/gimp-developer-list
>
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

Developers mailing list
https://i.imgur.com/TciFDZy.png

On Thu, Jan 3, 2019 at 10:57 AM Julien Hardelin <[hidden email]> wrote:

>
> I tried this before posting, using Layer Boundary Size to make the layer size bigger : it doesn't work.
>
> Le 02/01/2019 à 22:38, Alexandre Prokoudine a écrit :
>
> The layer has to be the size of the canvas or at least somewhat larger than its contents
>
> Alex
>
> ср, 2 янв. 2019 г., 20:39 Julien Hardelin [hidden email]:
>>
>> Hi devs,
>>
>> With Gimp-2.10.8 and Gimp-2.99, under different systems and computers,
>> the Drop Shadow filter doesn't work: nothing happens when I use it.
>> (Drop Shadow (legacy) works perfectly)
>>
>> Is this due to work in progress or to something I don't understand in
>> using it?
>>
>> Julien
>>
>> _______________________________________________
>> gimp-developer-list mailing list
>> List address:    [hidden email]
>> List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
>> List archives:   https://mail.gnome.org/archives/gimp-developer-list
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

julien-5
I tried and tried again in all possible ways, and no , it doesn't work.

That's a problem.

Please, give me your step by step procedure.

Julien

Le 04/01/2019 à 13:09, Alexandre Prokoudine via gimp-developer-list a
écrit :

> https://i.imgur.com/TciFDZy.png
>
> On Thu, Jan 3, 2019 at 10:57 AM Julien Hardelin <[hidden email]> wrote:
>> I tried this before posting, using Layer Boundary Size to make the layer size bigger : it doesn't work.
>>
>> Le 02/01/2019 à 22:38, Alexandre Prokoudine a écrit :
>>
>> The layer has to be the size of the canvas or at least somewhat larger than its contents
>>
>> Alex
>>
>> ср, 2 янв. 2019 г., 20:39 Julien Hardelin [hidden email]:
>>> Hi devs,
>>>
>>> With Gimp-2.10.8 and Gimp-2.99, under different systems and computers,
>>> the Drop Shadow filter doesn't work: nothing happens when I use it.
>>> (Drop Shadow (legacy) works perfectly)
>>>
>>> Is this due to work in progress or to something I don't understand in
>>> using it?
>>>
>>> Julien
>>>
>>> _______________________________________________
>>> gimp-developer-list mailing list
>>> List address:    [hidden email]
>>> List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
>>> List archives:   https://mail.gnome.org/archives/gimp-developer-list
> _______________________________________________
> gimp-developer-list mailing list
> List address:    [hidden email]
> List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
> List archives:   https://mail.gnome.org/archives/gimp-developer-list
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

Developers mailing list
In reply to this post by Developers mailing list
On Fri, Jan 04, 2019 at 03:09:21PM +0300, Alexandre Prokoudine via gimp-developer-list wrote:
> https://i.imgur.com/TciFDZy.png

Sorry, no:

https://imgur.com/a/8OepPGF

what system/gimp-version are you using?

Mine is Ubuntu 18.04 with dev 2.10 branch gimp ...

--


Marco Ciampa

I know a joke about UDP, but you might not get it.

------------------------

 GNU/Linux User #78271
 FSFE fellow #364

------------------------

_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

Developers mailing list
The GEGLized drop shadow filter is a big regressin in 2.10 -
nonetheless it works, in a destructive way (while the legacy
dropshadow works in a
non destructive way, and even allows adjusting the effect by
displacing the created
shadow layer).

So - it actually only works in a whole layer, is there are no active
selections -
if you are seeing nothing (and have space in the layer), maybe the problem is
that you have an active selection. The legacy drop shadow works
in a similar way, by changing the active layer, if there is an
active selection. The existing GEGL filter have no equivalent mode
to the one that would create a shadow for the selection itself in the
old filter.


On Fri, 4 Jan 2019 at 14:36, Marco Ciampa via gimp-developer-list
<[hidden email]> wrote:

>
> On Fri, Jan 04, 2019 at 03:09:21PM +0300, Alexandre Prokoudine via gimp-developer-list wrote:
> > https://i.imgur.com/TciFDZy.png
>
> Sorry, no:
>
> https://imgur.com/a/8OepPGF
>
> what system/gimp-version are you using?
>
> Mine is Ubuntu 18.04 with dev 2.10 branch gimp ...
>
> --
>
>
> Marco Ciampa
>
> I know a joke about UDP, but you might not get it.
>
> ------------------------
>
>  GNU/Linux User #78271
>  FSFE fellow #364
>
> ------------------------
>
> _______________________________________________
> gimp-developer-list mailing list
> List address:    [hidden email]
> List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
> List archives:   https://mail.gnome.org/archives/gimp-developer-list
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

julien-5
Wel, I progress.

With text layers, GEGL and Legacy Drop Shadow filters work the same.

With images, to get, with the GEGL filter, the same effect as the Legacy
filter, I must use a complex procedure:

- Open the original image

- Open a transparent image a little bigger than the original image.

- Copy-paste the original image into the transparent image.

- This creates a floating selection. Anchor the floating selection.

- Apply GEGL Drop Shadow.

Voilà.

All my attempts using resizing layer failed. Is there a simpler, at
once, way to do this as with the legacy filter?

Julien

Le 05/01/2019 à 03:18, Joao S. O. Bueno via gimp-developer-list a écrit :

> The GEGLized drop shadow filter is a big regressin in 2.10 -
> nonetheless it works, in a destructive way (while the legacy
> dropshadow works in a
> non destructive way, and even allows adjusting the effect by
> displacing the created
> shadow layer).
>
> So - it actually only works in a whole layer, is there are no active
> selections -
> if you are seeing nothing (and have space in the layer), maybe the problem is
> that you have an active selection. The legacy drop shadow works
> in a similar way, by changing the active layer, if there is an
> active selection. The existing GEGL filter have no equivalent mode
> to the one that would create a shadow for the selection itself in the
> old filter.
>
>
> On Fri, 4 Jan 2019 at 14:36, Marco Ciampa via gimp-developer-list
> <[hidden email]> wrote:
>> On Fri, Jan 04, 2019 at 03:09:21PM +0300, Alexandre Prokoudine via gimp-developer-list wrote:
>>> https://i.imgur.com/TciFDZy.png
>> Sorry, no:
>>
>> https://imgur.com/a/8OepPGF
>>
>> what system/gimp-version are you using?
>>
>> Mine is Ubuntu 18.04 with dev 2.10 branch gimp ...
>>
>> --
>>
>>
>> Marco Ciampa
>>
>> I know a joke about UDP, but you might not get it.
>>
>> ------------------------
>>
>>   GNU/Linux User #78271
>>   FSFE fellow #364
>>
>> ------------------------
>>
>> _______________________________________________
>> gimp-developer-list mailing list
>> List address:    [hidden email]
>> List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
>> List archives:   https://mail.gnome.org/archives/gimp-developer-list
> _______________________________________________
> gimp-developer-list mailing list
> List address:    [hidden email]
> List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
> List archives:   https://mail.gnome.org/archives/gimp-developer-list
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

Developers mailing list
On Sat, Jan 05, 2019 at 09:07:11AM +0100, Julien Hardelin wrote:

> Wel, I progress.
>
> With text layers, GEGL and Legacy Drop Shadow filters work the same.
>
> With images, to get, with the GEGL filter, the same effect as the Legacy
> filter, I must use a complex procedure:
>
> - Open the original image
>
> - Open a transparent image a little bigger than the original image.
>
> - Copy-paste the original image into the transparent image.
>
> - This creates a floating selection. Anchor the floating selection.
>
> - Apply GEGL Drop Shadow.
>
> Voilà.

I did:

- Open the original image

- If not present add an alfa channel

- Select the object you want to drop a shadow

- Invert the selection

- Cut the selection

- Past the selection into another layer

- Put that layer as the bottom layer

- Select the first/object layer

- Remove any selection

- Drop the shadow


--


Marco Ciampa

I know a joke about UDP, but you might not get it.

------------------------

 GNU/Linux User #78271
 FSFE fellow #364

------------------------

_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

Developers mailing list
In reply to this post by Developers mailing list
пт, 4 янв. 2019 г., 19:36 Marco Ciampa:

> On Fri, Jan 04, 2019 at 03:09:21PM +0300, Alexandre Prokoudine via
> gimp-developer-list wrote:
> > https://i.imgur.com/TciFDZy.png
>
> Sorry, no:
>
> https://imgur.com/a/8OepPGF


I really have no idea what's going on in your case.

I'm on Ubuntu 18.10 and GIMP from gimp-2-10 master branch, although it
doesn't change a thing -- it's been working for me since the beginning.

1. New image
2. New layer
3. Select, fill with color
4. Crop to content
5. Enlarge layer boundary
6. Launch the GEGL op in question.

Or even simpler, with a text layer:

1. New image
2. New text layer with some text
3. Layer to image size
4. Launch the GEGL op in question.

In both scenarios, the GEGL-based filter works just like on my screenshot.

Alex
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

Developers mailing list
On Sat, Jan 05, 2019 at 10:38:19PM +0300, Alexandre Prokoudine via gimp-developer-list wrote:

> пт, 4 янв. 2019 г., 19:36 Marco Ciampa:
>
> > On Fri, Jan 04, 2019 at 03:09:21PM +0300, Alexandre Prokoudine via
> > gimp-developer-list wrote:
> > > https://i.imgur.com/TciFDZy.png
> >
> > Sorry, no:
> >
> > https://imgur.com/a/8OepPGF
>
>
> I really have no idea what's going on in your case.
>
> I'm on Ubuntu 18.10 and GIMP from gimp-2-10 master branch, although it
> doesn't change a thing -- it's been working for me since the beginning.
>
> 1. New image
> 2. New layer
> 3. Select, fill with color
> 4. Crop to content
> 5. Enlarge layer boundary
> 6. Launch the GEGL op in question.
>
> Or even simpler, with a text layer:
>
> 1. New image
> 2. New text layer with some text
> 3. Layer to image size
> 4. Launch the GEGL op in question.
>
> In both scenarios, the GEGL-based filter works just like on my screenshot.

Sorry, I was not clear in my last example message.
After the example of Julien I was able to figure out how that filter worked
and managed to make it work. It was not immediate though... at least to me
that admittedly am not such a great (not at all) GIMP user...

Anyway thanks for clarifying it to me...

--


Marco Ciampa

I know a joke about UDP, but you might not get it.

------------------------

 GNU/Linux User #78271
 FSFE fellow #364

------------------------

_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list
Reply | Threaded
Open this post in threaded view
|

Re: GEGL Drop Shadow filter not working

julien-5
Thank you Alex for your explanation : I missed Crop to content.

Julien

_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list