Basics and getting started

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Basics and getting started

Paul Thompson
I am beginning a project about enabling a script recorder (you do actions,
they are recorded for later playback).

Thus far, I have done the following:

1) Within Windows 10, downloaded and installed msys. Following well-written
instructions (which worked 100% correctly), I downloaded tools, installed
babl, gegl, and gimp. Using again these excellent instructions, I compiled
the developmental gimp-2.9. I can run this version.

2) Following instructions found at

http://lightningismyname.blogspot.de/p/compiling-gimp.html

I compiled gimp-2.9 with the debug flag. Now, when I run gimp-2.9, debug
messages appear in my msys command tool window. All good.

3) I am now trying to understand how to modify the program. I have put a
few probe-type commands in various places. Since I get a debug message from


gimp/app/display/gimpdisplayshell-profile

I accessed this file and modified by adding another line with a modified
message directly above the line showing up in the debug.

4) make -j4 and make install -j4 are both successful

5) In running gimp-2.9, my added line, and other lines in other programs do
not show up. Checking dates/times, all .o files are compiled up to date.

What have I omitted in this process?

Paul A. Thompson
_______________________________________________
gimp-developer-list mailing list
List address:    [hidden email]
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list